RİP (Routing İnformation Protocol)

Bu məqalədə RİP protokolun işləmə prinsipləri və funksiyaları ilə tanış olacağıq. RİP dinamik marşuritizasiya protokoludu və kiçik  şəbəkələr  üçün nəzərdə tutulub. Marşrutlar haqda informasiyaları UDP 520 portundan istifadə etməklə paylaşır.  Digər məsafə vektorlu (distance vector) protokollar kimi RİP-də vaxtdan istifadə edərək  marşuritizasiya məlumatların aralarında bölüşürlər. Lakin digər protokollardan fərqli olaraq RİP daha az CPU və RAM istifadə edir. RİP protokolu daha kiçik həcmli şəbəkələr üçün nəzərdə tutulduğuna görə onun digərlərdən fərqi  və məhdudiyyəti vardır. RİP ən yaxşı marşrutu sıçrayışlara əsasən (hop count) təyin edir. Məsələn  mənzil başina çatmaq üçün RİP ən yaxın olan məsafəni ən yaxşı marşrut kimi  özündə qeyd edir. Bu marşrut ozündə  zəif  ya sürətli  data kanallarınıda əks etdirə bilər RİP bunun fərqinə varmır.  RİP-in aşağıdakı çatışmamazlıqları vardır. Rip Məsafə vektoru ilə işləyən protokoldu və aşağıdakı mənsubiyyətləri vardır. Sıçrayışlarla optimal  marşrutu seçir- hər sıçrayış bir router anlamıdı, (hop count) 15 saydan sonra (15 router nəzərdə tutulur)  16-cı artıq əlçatmaz hesab olunur. 15 nöqtədən sonra  packet  yox olur yəni 15 router-dən keçən paket 16 gedib çatmır və həmin marşrut  bu router üçün əlverişli hesab olunmur. Bu faktor həmçinin marşrutun təkrarən   marşrut cədvəlinə daxil olunmasının qarşısını alır. Buna “routing loop” deyilir. Bu  protokola əlavə olunmuş split horizon və reverse poison vasitəsilə təkrar əks tərəfə gələn anonsların qarşısını almaq üçün istifadə  olunur.

RIP

RİP classful  routing protokol hesab olunur yəni  bu protokol  şəbəkə adreslərin düzgün  anons olunmasını əks edə bilmir. İp adreslərin bölgüsü deyəndə İP adres diapazonunu yeniden  bölünərsə bu halda RİP 1 versiya bu bölgünü oldüğü qaydada digər şəbəkələrə çatdıra bilməz. Deyək ki, bizim 172.16.16.0  255.255.255.0 diapazonumuz var və biz onu   bölüb bir neçə diapozun  əldə etmək istəyirik—172.16.16.0 255.255.255.252 bu zaman RİP1 versiya bu ip adresi 172.16.16.0 kimi anons edəcəkdir. Belə desək subneti maskasız  anons edir.
Rip 6 muxtəlif marşrutlardan eyni zamanda istifadə edə bilir yəni, eyni vaxtda paketin getdiyi mənzilə cədvəlində olan 8 yerdən marşrut varsa onlardan 6 eyni zamanda istifadə edə bilir. Həmçinin eyni həcmli və  eyni məsafəyə malik olan cığırları, yükləri balanslaşdıraraq paketleri yönəldir.
Rip ozünün anonslarını böyük diapozonla (broadcast) elan edir bütün şəbəkəyə bu da  sürəti zəif olan  linklər üçün problem yaradır. Əgər cədvəlində xeyli sayda marşrut varsa və hər 30 saniyədən bir anons edirsə o zaman zəif  kanallar böyük təsirə məruz qalıırlar. Bunuda qarşısını almaq üçün  həmin linklərdə passiv  port kimi göstərilir və buda həmin anonsların həmin linkə daxil olmasının qarşısını alır.
Anonslar arasında imterval 30 saniyə. 180 saniyə əgər anons olunan marşrut bu vaxt ərzində yenilənmirsə səhf marşrut kimi  göstərilir və həmin marşrutda qeyd olunan bütün şəbəkə  diapozonları üçün heç bir anons olunmur, novbəti prosedura qədər. 240 saniyə ərzində isə həmin marşrut cədvəldən silinir.
Məsafə vektoru ilə işləyən protokolların ən böyük problemi marşrut qarşılığıdır. Gəlin bunun baş verməsini nəzərdən keçirək.
Bizim 3 routerimiz R1,R2,R3. Onu da qeyd edim ki əgər bizim dinamik ya static protokolumuz işə salınmayıbsa  router R1 –R2 ilə əlaqə yarada bilməz. Yəni 12-ci  şəbəkə R2 ilə əlaqə qura bilməz.  Router R1-da şəbəkə 192.168.12.0 artıq qeydə alınıb çünki bu diapazon birbaşa qoşulu olduğu üçün onun ölçüsü 0 kimi diaqramda göstərilmişdir. Eynilə digər routerlərdə də bu parametrlər öz yerini tapmışdır.

01

Biz RİP protokolunu işə salsaq  o zaman hər bir router ozündə olan  şəbəkə diapozonları anons edəcəkdir. Yəni, Rip öz cədvəlində olan  diapozonları nüsxəsini hər 30 saniyədən bir digərlərinə anons edir.Bu halda  router R1 öz cədvəlində olan  marşrutları R2-yə göndərir və R2 artıq 192.168.10.0 şəbəkəsi  haqqında məlumatı vardır, çünki birbaşa bağlantısı var. Lakin 192.168.12.0 diapazonunu öz cədvəlinə daxil edir. Beləliklə  digər routerlərdə bu  şəkildə özlərində olan   şəbəkə diapazonların  nüsxəsini digərlərinə  elan edirlər.

02

03

04

Və sonda topologiyada göstərilən bütün routerlər  marşrut cədvəlləri  eyniləşmişdir. Lakin  R2 router şəbəkə 192.168.13.0 düşməsini qeydə alır.

05

Router  R2 həmin istiqamətdə özünün  marşrut anonslarını saxlayır. Amma R1 və R2 bundan xəbəri olmur və R1 inanır ki,  bu diapazonla  R2  gedib çıxmaq olur və R2 isə R3-dən çıxışını özündə  saxlayır. Əgər R3 bu problem haqda ilk digərlərini xəbərdar edərsə bu zaman heç bir problem yaranmaz. Əgər bunu R2 anons edərsə o zaman R3  özünün cədvəlində qeyd edir həmin marşrutu və həmin şəbəkəyə R2-dən  çıxış olduğunu qeyd edir.  R3 özlüyündə düşünür ki, əgər  R2 2 sıçrayışla bu şəbəkəyə  çıxa bilirsə demək mən buna 3 sıçrayışa çata bilərəm.

06

07

Bu problem davamlı olaraq R2 tərəfdən anons olursa R3-ə onda  bu anonslar sonsuz  olur və eyni anons təkrarlanır. Bu sonsuza saymaq (Counting to infinity)  adlanır. Bu xüsusiyyətlər vasitəsilə bu kimi problemlərin qarşısı alınır.
Split Horizon:
Bu proses  gələn  informasiyanı geri həmin  routerə göndərilməsinin qarşısını alır.Yəni  router R1 R2-yə anons etdiyi marşrutu R2 anons edə bilmir çünki həqiqi  marşrut  R1 routerdə yerləşir.
Route poisoning:
Bu  marşrutun  sona çatdığını bildirir. Misal üçün router R3  13 şəbəkəsinin düşdüyünü biləndə o digər routerlərə anons edir ki, həmin marşrut 16  sıçrayışdan sonra çatmaq  mümkündü.  Bu bütün routerlərə bəlli edir ki, həmin marşrut əlçatmazdı.
Poison Reverse:
Bu qayda  Split Horizon qaydasını qarşısını alır. Bu halda router R2 R3-dən aldığı zəhərli marşrutu yenidən ona anons edir  və say 16 göstərilməklə R3-ü əmin edir ki, bu  problem haqda hər birimizin xəbərimiz var.
Holddown Timers:
Marşrutun qarışdığını- zəhərləndiyini biləndən sonra  router  müəyyən saniyələr dayanır və heç bir anons qəbul etmir. Həmin vaxtı  marşurun zəhərləndiyini qeydə alan və anons edən router  daha yaxşı marşrut anons edərsə onu qəbul edir  və dayanma vaxtını yekunlaşdırır. Lakin həmin marşurut rədd olunur əgər o digər router-dən anons olarsa. Bu dayanma vaxtı 180 saniyədi.
Triggered Update:
Bu zaman marşrut itərsə və növbəti anonsu gözləmədən  dərhal marşrutun zəhərlənməsi ya garışdığını elan  olunan halıdır
RİP 1 versiyada protokolun göndərdiyi anonslar  açıq mətində  elan olunur  və bu hal  2 – ci versiyada artıq  kripto şəklində elan olunur. Bu protokolun yaxşı xüsusiyyətlərindən biridə onun  vendor  spesifik olmamasıdır, yəni hər bir avadanlıq və çox əməliyyat sistemlərində istifadə olunur.
RİP v2 v1-dən fərqli olaraq bütün anonsları şifrlənmiş şəkildə göndərir və şəbəkə diapazonların anons ovunmasını Rip v1 –dən fərqli olaraq bütünlüklə  anons edir. Yəni   şəbəkə diapazonuna maskası daxil olmaqla anons edir. Demək olar ki, hər iki protokol eyni mahiyyəti daşıyır lakin RİP v2  RİP  v1-dən bəzi xüsusiyyətlərinə görə fərqlənir.
Fərqlər:
Marşrut anonslarında növbəti routerin adresinin qeyd olunması
Broadcast əvəzinə Multicast anonsların göndərilməsi
Şifrələnmənin mövcud olması

Konfiqurasiyası çox sadədir.

08

CİSCO cihazları üçün:
Rip v1
conf t
interface FastEthernet0/0
description R1-R2
ip address 192.168.10.1 255.255.255.0
router rip
network 192.168.10.0
interface FastEthernet0/0
description R2-R1
ip address 192.168.10.2 255.255.255.0
interface FastEthernet0/1
description R2-R3
ip address 192.168.11.1 255.255.255.0
router rip
network 192.168.10.0
network 192.168.11.0
interface FastEthernet0/1
description R3-R2
ip address 192.168.11.2 255.255.255.0
router rip
network 192.168.11.0

RİPv2
key chain rip
key 1
key-string cisco
interface FastEthernet0/0
ip rip authentication mode md5
ip rip authentication key-chain rip
router rip
version 2
eyni qayda ilə bütün interface-də göstərilir

 Juniper cihazları üçün:
M10i router:

interfaces {
fe-0/3/0 {
unit 0 {
family inet {
address 172.16.6.10/24;
}
}
}
lo0 {
unit 0 {
family inet {
address 1.1.1.1/32;
}
}
}
}
protocols {
rip {
group RIP_GROUP {
neighbor fe-0/3/0.0;
neighbor lo0.0;
}
}
}
group RIP_GROUP {
neighbor ge-0/0/0.0 {
metric-in 5;
authentication-type md5;
authentication-key “$9$96RKt0IylMNdsEcds24DjCtu”; ## SECRET-DATA
}

Ətraflı məlumat üçün http://en.wikipedia.org/wiki/Routing_Information_Protocol burada tanış ola bilərsiniz. Bu məqalənin ərsəyə gəlməsində xüsusi əməyi keçən Amal bəyə təşəkkürümüzü bildiririk.

Ağa Hüseynov

____________

CCNP

Səs: +10. Bəyənilsin Zəifdir

Müəllif: Ağa Hüseynov

Şərhlər ( 8 )

    • Amal / . Dərc edilib:A 14/03/2013 at 3:27 PM
      Səs: 0. Bəyənilsin Zəifdir

    Salam,

    Məqaləyə zəhmət çəkdiyiniz üçün təşəkkür edirəm. Amma məzmun baxımından bir qədər diqqətli olmağınızı məsləhət görərdim. Qeydlərimi bildirmək istərdim.

    RIP hər 30 saniyədən bir rout yenilikləri göndərsə də, 120 saniyədən sonra cavab gəlməzsə, routu silmir. Deyəsən OSPF routinq protokolu ilə səhv salmısınız. RIP routinq protokolunun vaxtları update:30, invalid: 180, holddown: 180 flush:240. RIP 180 saniyə qarşı tərəfdən rout yeniliyi almazsa, sadəcə həmin route-u down vəziyyətə salır, amma həmin şəbəkəyə paket rout edir. Paketlər qara dəliyə yollanılır. Routu yalnız 7 dəqiqədən sonra silinir. Bu isə şəbəkədə dirilmə (convergence) vaxtına təsir edir. Məhz bu səbəbə görə RIP routinq protokolu şəbəkə aləmində məhşurluq qazanmadı. Amma RIP protokolu şəbəkə protokollarının iş prinsipi anlamaqda cox vacibdir.

    Konfiqurasiyanız RIP version 1 üçündür. Səhvdir. RIP v1 isə authentication dəstəkləmir.

    Topologiyada çox sadə bir konfiqurasiya ilə T1 xəttlərin seçilməsinə nail olmaq olar. Bu RIP protokolundan imtina etməyin səbəbi deyil. Səbəb bu protokolun dirilmə vaxtının gec olmasıdır.

  1. Salam,
    Amal bəy mövzu üzərindəki texiniki çatışmazlıq aradan qaldırlmışdır. Vaxt ayırıb diqqət göstərdiyiniz üçün çox sağolun.

    Uğur olsun.

    • Amal / . Dərc edilib:A 19/03/2013 at 7:47 PM
      Səs: 0. Bəyənilsin Zəifdir

    Salam,

    Məqalədən:

    Rip 6 muxtəlif marşrutlardan eyni zamanda istifadə edə bilir yəni, eyni vaxtda paketin getdiyi mənzilə cədvəlində olan 8 yerdən marşrut varsa onlardan 6 eyni zamanda istifadə edə bilir. Həmçinin eyni həcmli və eyni məsafəyə malik olan cığırları, yükləri balanslaşdıraraq paketleri yönəldir.

    Amaldan:

    Səhvdir. RIP son məntəqəyə çatmaq üçün eyni metrikə malik olan nə 6, nə də 8 routdan istifadə edir. RIP ilkin olaraq (default), son məntəqəyə çatmaq üçün eyni metrikə malik olan 4 routdan istifadə edir. Maksimum olaraq, eyni metrikə malik olan 16 routdan istifadə etməsi üçün konfiqurasiya edilə bilər.

    Məqalədən:

    Rip ozünün anonslarını böyük diapozonla (broadcast) elan edir bütün şəbəkəyə bu da sürəti zəif olan linklər üçün problem yaradır. Əgər cədvəlində xeyli sayda marşrut varsa və hər 30 saniyədən bir anons edirsə o zaman zəif kanallar böyük təsirə məruz qalıırlar. Bunuda qarşısını almaq üçün həmin linklərdə passiv port kimi göstərilir və buda həmin anonsların həmin linkə daxil olmasının qarşısını alır.

    Amaldan:

    Səhvdir. Passiv interfeys texnologiyasının zəif sürətli kanallarla heç bir əlaqəsi yoxdur. Passiv interfeys texnologiyası RIP yeniliklərini (update) anlamayan son avadanlıqlara (kompüter, printer,server, ip telefon və s.) göndərilməsinin qarşının alınması üçün dizayn edilmişdir. Məsələn, kompüter RIP paketinin anlamırsa, bu zaman həmin paketi emal etməyəcək və rədd edəcək. Bu isə nəinki, kompüter ilə router/sviç/təhlükəsizlik avadanlığı (pix,asa və s.) arasındakı xəttin sürətinin, eləcə də kompüterin öz resurslarının (CPU, yaddaş, şəbəkə kartı) səmərəsiz olaraq istifadəsinə gətirib çıxardacaq.

    10.10.10.0/24 — Router1——passiv interfeys——Router2—10.10.20.0/24

    Tutaq ki, bu topologiyda RIP v2 aktivdir. Əgər biz Router1 ilə Router2 arasındakı interfeyslərə passiv interfeys texnologiyasını tətbiq etsək, bu zaman Router1 10.10.20.0/24 şəbəkəsi, Router2 isə 10.10.10.0/24 şəbəkəsi haqqında heç bir yenilik almayacaq. Bu isə şəbəkədə anormal vəziyyət yaradacaq. OSPF və EIGRP kimi ali səviyyəli routinq protokollar üçün isə bu daha da böyük problem yarada bilər.

    Məqalədən:

    Split Horizon:
    Bu proses gələn informasiyanı geri həmin routerə göndərilməsinin qarşısını alır.Yəni router R1 R2-yə anons etdiyi marşrutu R2 anons edə bilmir çünki həqiqi marşrut R1 routerdə yerləşir.

    Amaldan:

    Səhvdir. Split Horizon qaydası routerlar arasında deyil, daha dəqiq interfeyslər arasında baş verir. Split Horizon qaydasına görə bir routerin bir interfeysindən daxil olmuş routinq yeniliyi eyni interfeysdən geri yollanılmır.

    Məqalədən:

    Holddown Timers:
    Marşrutun qarışdığını- zəhərləndiyini biləndən sonra router müəyyən saniyələr dayanır və heç bir anons qəbul etmir. Hətta həmin vaxtı daha yaxşı marşrut anons olarsa onu belə rədd edir dayanma vaxtı bitməyənə kimi. Bu dayanma vaxtı 180 saniyədi

    Amaldan:

    Səhvdir. Router Holddown müddətində sadəcə eyni metrikə malik olan və ya daha pis metrikə malik olan routları routinq cədvələ daxil etmir. Daha yaxşı metrikə malik olan rout alarsa, onu routinq cədvələ salır və Holddown müddəti sıfırlanır.

    Məqalədəki hər bir bölməni simulyasiya edin və real olaraq nə baş verdiyini görün. Test edilməmiş və sadəcə tərcümə edilmiş məqalələrin heç bir faydası yoxdur və oxucunu səhv yola yönəldir.

    Uğurlar!

    Amal
    CCNA/CCNP/CCNA Security/CCAI

    • Amal / . Dərc edilib:A 19/03/2013 at 7:48 PM
      Səs: 0. Bəyənilsin Zəifdir

    Salam,

    Məqalədən:
    Rip 6 muxtəlif marşrutlardan eyni zamanda istifadə edə bilir yəni, eyni vaxtda paketin getdiyi mənzilə cədvəlində olan 8 yerdən marşrut varsa onlardan 6 eyni zamanda istifadə edə bilir. Həmçinin eyni həcmli və eyni məsafəyə malik olan cığırları, yükləri balanslaşdıraraq paketleri yönəldir.

    Amaldan:
    Səhvdir. RIP son məntəqəyə çatmaq üçün eyni metrikə malik olan nə 6, nə də 8 routdan istifadə edir. RIP ilkin olaraq (default), son məntəqəyə çatmaq üçün eyni metrikə malik olan 4 routdan istifadə edir. Maksimum olaraq, eyni metrikə malik olan 16 routdan istifadə etməsi üçün konfiqurasiya edilə bilər.

    Məqalədən:
    Rip ozünün anonslarını böyük diapozonla (broadcast) elan edir bütün şəbəkəyə bu da sürəti zəif olan linklər üçün problem yaradır. Əgər cədvəlində xeyli sayda marşrut varsa və hər 30 saniyədən bir anons edirsə o zaman zəif kanallar böyük təsirə məruz qalıırlar. Bunuda qarşısını almaq üçün həmin linklərdə passiv port kimi göstərilir və buda həmin anonsların həmin linkə daxil olmasının qarşısını alır.

    Amaldan:
    Səhvdir. Passiv interfeys texnologiyasının zəif sürətli kanallarla heç bir əlaqəsi yoxdur. Passiv interfeys texnologiyası RIP yeniliklərini (update) anlamayan son avadanlıqlara (kompüter, printer,server, ip telefon və s.) göndərilməsinin qarşının alınması üçün dizayn edilmişdir. Məsələn, kompüter RIP paketinin anlamırsa, bu zaman həmin paketi emal etməyəcək və rədd edəcək. Bu isə nəinki, kompüter ilə router/sviç/təhlükəsizlik avadanlığı (pix,asa və s.) arasındakı xəttin sürətinin, eləcə də kompüterin öz resurslarının (CPU, yaddaş, şəbəkə kartı) səmərəsiz olaraq istifadəsinə gətirib çıxardacaq.

    10.10.10.0/24 — Router1——passiv interfeys——Router2—10.10.20.0/24

    Tutaq ki, bu topologiyda RIP v2 aktivdir. Əgər biz Router1 ilə Router2 arasındakı interfeyslərə passiv interfeys texnologiyasını tətbiq etsək, bu zaman Router1 10.10.20.0/24 şəbəkəsi, Router2 isə 10.10.10.0/24 şəbəkəsi haqqında heç bir yenilik almayacaq. Bu isə şəbəkədə anormal vəziyyət yaradacaq. OSPF və EIGRP kimi ali səviyyəli routinq protokollar üçün isə bu daha da böyük problem yarada bilər.

    Məqalədən:
    Split Horizon:Bu proses gələn informasiyanı geri həmin routerə göndərilməsinin qarşısını alır.Yəni router R1 R2-yə anons etdiyi marşrutu R2 anons edə bilmir çünki həqiqi marşrut R1 routerdə yerləşir.

    Amaldan:
    Səhvdir. Split Horizon qaydası routerlar arasında deyil, daha dəqiq interfeyslər arasında baş verir. Split Horizon qaydasına görə bir routerin bir interfeysindən daxil olmuş routinq yeniliyi eyni interfeysdən geri yollanılmır.

    Məqalədən:
    Holddown Timers:Marşrutun qarışdığını- zəhərləndiyini biləndən sonra router müəyyən saniyələr dayanır və heç bir anons qəbul etmir. Hətta həmin vaxtı daha yaxşı marşrut anons olarsa onu belə rədd edir dayanma vaxtı bitməyənə kimi. Bu dayanma vaxtı 180 saniyədi

    Amaldan:
    Səhvdir. Router Holddown müddətində sadəcə eyni metrikə malik olan və ya daha pis metrikə malik olan routları routinq cədvələ daxil etmir. Daha yaxşı metrikə malik olan rout alarsa, onu routinq cədvələ salır və Holddown müddəti sıfırlanır.

    Məqalədəki hər bir bölməni simulyasiya edin və real olaraq nə baş verdiyini görün. Test edilməmiş və sadəcə tərcümə edilmiş məqalələrin heç bir faydası yoxdur və oxucunu səhv yola yönəldir.

    Uğurlar!
    Amal
    CCNA/CCNP/CCNA Security/CCAI

  2. Amal bəy sizə minnətdaram ki, vaxt ayırıb diqqət verdiniz.

    1. RIP can support up to 6 equal path( 4 by default). “Default” avadanlıqda əlavə işlər görülmədikdə onun protokolun xüsusuyyətinə uyğun olaraq istifadə etdiyi sazlamalardı. Amma bunuda bilməliydiz ki, yazdığınız “16” Cisco tərəfdən əlavə olunmuşdür və bu 16 path 12.4 İOS-dan sonra istifadə oluna bilər.

    2. Passiv interface özünüzdə qeyd etmisiz ki, resusrlara qənaət etmək üçün istifadə olunur. Bu komanda ilə həm bandwidth həmdə avadanlığın resusrlarına qənaət etmək faydasını vermək olur.

    3. Bu bənd də router yox başqa bir cihazda yazıla bilərdi lakin bizə maraqlı olan məntiqin düz olmasıdı.

    4. Holddown-a bəli burada tex. səhfə yol verilib bunuda dəyişiklik olacaqdır.

    5. O ki, qaldı birinci yazdığınız marşurutun 7 dəq. sonra silinməsinə onu bilmək istərdim hardan əldə etmisiz bizidə məlumatlandırardız.

    PS. Hətta onuda qeyd edim ki, 15.0 İOS-da bu path artıq 32 qədər çatır
    Təşəkkürlər.

    • Amal / . Dərc edilib:A 20/03/2013 at 7:48 PM
      Səs: 0. Bəyənilsin Zəifdir

    Salam,

    İlk olaraq, qeyd edim ki, biz texniki məsələlər barəsində müzakirə edirik. Dəqiqlik çox vacibdir.

    1. Məqalə Cisco bölməsi altında yerləşdirildiyi üçün Cisco-nun texnologiyalarından və yeniliklərindən yazırıq. Ola bilsin ki, hansısa şəbəkə məsələsində Microsoft və ya digər şirkət başqa bir dəlil gətirsin, amma biz Cisco nə deyirsən onunla razılaşmalıyıq. Ona görə də, RIP ilkin olaraq (default), son məntəqəyə çatmaq üçün eyni metrikə malik olan 4 routdan istifadə edir. Maksimum olaraq, eyni metrikə malik olan 16 routdan istifadə etməsi üçün konfiqurasiya edilə bilər.

    2/3. Passiv interfeys ilə bağlı məntiq tamamilə səhvdir. Passiv interfeys məhz router ilə RIP protokolunun paketlərini anlamayan avadanlıqlar arasında olan interfeysdə aktiv edilməlidir. Belə də yazılmalı idi ki, oxucu səhv anlamasın. Oxucu məqaləni oxuyur və serial interfeys ilə bir-birinə bağlı olan iki router arasındakı interfeyslərdə sürət az olduğuna görə passiv interfeys texnologiyasından istifadə edir və bütün şəbəkəni diziüstə qoyur. RIP protokolundan istifadə edən routerlar arasında passiv interfeys texnologiyasından qətiyyən istifadə edilmir.

    4. səhf yox səhv. Holddown vaxtının işləmə prinsipi CCNA kursunun mövzusudur. Ətraflı məlumat üçün Cisco Exploration 4.0 dərsliyinin RIP bölməsinə müraciət edə bilərsiniz.

    5. 7 dəqiqə – routun routinq cədvəldə qeyd edilməsindən, həmin routun silinməsinə qədər olan vaxtdır, yəni həmin rout problemli olarsa, və heç bir digər routerdan daha yaxşı metrikə malik olan eyni rout alınmazsa, yalnız 7 dəqiqədən sonra routinq cədvəldən silinəcək və 7 dəqiqə ərzində həmin routa paketlər göndəriləcək amma paketlər qara dəliyə yollanılacaq.

    Məqalə iki dəfə nəşr edilib və hər dəfə də səhvlərlə doludur. Deyəsən sonda məqalənin müəllifləri arasında mənim adımı qeyd ediləcək 🙂 Bir az yumor.

    Uğurlar!

  3. Salam,
    Yaxşı olardı bir az araşdırma aparardız rip bandwidth consumtion haqqında.
    əgər hər dəfə eyni yazdıqlarınızı copy paste ediləcəksizsə onda buyurun zəhmət çəkib bir az məlumatlanın.

    Quit wasting bandwidth by controlling Cisco routing protocol updates
    http://www.techrepublic.com/article/quit-wasting-bandwidth-by-controlling-cisco-routing-protocol-updates/6127576

    O ki qaldı 7 dəq. onuda araşdırmanız ıazımdı
    Çünki siz dediyiniz qaydada coxları düşünür amma bu belə deyil.
    marşurutun silinməsi 4 dəq sonra baş verir
    https://learningnetwork.cisco.com/thread/24749
    https://learningnetwork.cisco.com/thread/24480
    https://learningnetwork.cisco.com/thread/25179
    https://learningnetwork.cisco.com/thread/27324

    unutmayın ki, 240+180 olmur
    default qayda 3×60+60
    Güman edirəm bu məlumat kifayət edir.
    Təşəkkür.

    • Amal / . Dərc edilib:A 04/04/2013 at 12:46 PM
      Səs: 0. Bəyənilsin Zəifdir

    Salam,

    Gec yazdığım üçün üzr istəyirəm. RIP routun silinməsi Packet Tracer-də 7 dəqiqə çəkir. Real routerda 4 dəqiqədən sonra silinir. 4 dəqiqə ilə razılaşdım.

    Sağ olun.

Şərh yazın