Cisco wireless controller nədir?

Salam,bugün biz Cisco wireless controller haqqında danışıb, topologiyada tətbiqini görəcəyik. Wireless controller vasitəsilə biz mərkəzdən access pointlərimizi rahat idarə edə bilərik. Geniş topologiyalarda bu bizim üçün çox əlverişli olacaqdır.

LWAPP protokolu (Lightweight Access Point Protocol) wireless controller ilə Lightweight Access pointlər arasında əlaqə yaradan protokoldur.

Lightweight Access Pointlər enerjini ethernet vasitəsilə alırlar ,bununla bərabər quraşdırmada biz həm zamana,həm əlavə enerji qaynaqlarından istifadə etməməyə qənaət etmiş oluruq.

Indi isə gəlin topologiyamız haqqında danışaq,bunun üçün biz bir 2911 Cisco İntegrated Service router ,3750 switch ,3 ədəd Lightweight Access Point,1 ədəd 5760 wireless controllerdən istifadə edəcəyik.TechnetWLC

 

Userlərimiz VLAN 10-da olacaqlar ,access pointlər və Wireless controller isə VLAN 20 aralığında olacaqlar.İndi isə topologiyamızda istifadə edəcəyimiz İP cədvəlimizə nəzər salaq.

Cihaz Vlan Ip Adres
Router 10,20 11.0.0.1 ,172.16.20.1
Switch 10,20 11.0.0.2 ,172.16.20.2
Wireless controller 20 172.16.20.5
NTP server 11.0.0.1
Access Pointlər 20 172.16.20.0/24
İstifadəçilər 10 11.0.0.0/24

Gəlin əvvəlcə routərdəki bəzi output-lara nəzər salaq.

show ip interface brief komandası ilə interfeyslərdəki ip adreslərə baxaq.

routerip

Router-imizdə iki DHCP yaradırıq, biri userlər üçün biri isə Access Pointlər üçündür.

routerdhcp

İndi isə keçək switch üzərindəki konfiqurasiyalara.Switch üzərində iki ədəd vlan olacaqdır.

Bütün userler vlan 10-da yerləşəcəkdir,access Pointlər isə vlan 20-də.

vlansw

Vlan-larımıza İp adresi verək.

interface Vlan10

 ip address 11.0.0.2 255.255.0.0

interface Vlan20

 ip address 172.16.20.2 255.255.255.0

Daha sonra switch və WLC arasındakı əlaqə üçün port-channel yaradaq.

Saphire_SW(config)#interface port-channel 10

Saphire_SW(config-if)#no shutdown

Saphire_SW(config-if)#exit

Saphire_SW(config)#interface range GigabitEthernet1/0/1-2

Saphire_SW(config-if-range)#channel-group 10 mode desirable

Saphire_SW(config)#interface port-channel 10

Saphire_SW(config-if)#switchport mode trunk

Saphire_SW(config-if)#switchport trunk encapsulation dot1q

Saphire_SW(config-if)#switchport trunk allowed vlan 1,10,20

Spoofingin qarşısını almaq üçün isə biz aşağıdakı komandları icra edirik.

ip dhcp snooping vlan 10,20

 no ip dhcp snooping information option

ip dhcp snooping

interface range FastEthernet1/0/37-39

 switchport access vlan 20

 switchport mode access

spanning-tree portfast

Mən switchdə 37,38 və 39-cu portlara access pointləri taxacam. Access Pointlər VLAN 20-də olacaqlar və 172.16.20.0/24 aralığından İP alacaqlar.

Indi isə keçək ən önəmli konfiqurisayalara ,hansı ki çox işlər Wireless controller üzərində olacaqdır.Console kabelimizi taxıb konfiqurasiya üçün controllerə daxil oluruq.

2

Contollerə Technet-WLC adını verdik ,daha sonra enable secret və enable password-ə isə cisco verərək davam edirik.3

Indi isə NTP serverimizi konfiqurasiya edək ,bu bizim routeremiz olacaqdır,ona görə də routerin İP adresini verdim.Sırada isə  service port var ,bu port WLC boot olan zaman aktiv olan yeganə portdur ,bu porta isə İP verməyə bilərik.Bu port hətda 802.1Q paketlərini belə dəstəkləmir.4

Management interface isə bizim 20-ci vlan olacaqdır ,sabit bir İP verərək davam edirik.5

2 –ci variantı seçib davam edirik.

WLC üzərindəki interfeyslərə nəzər salırıq, switch və wlc arasındakı əlaqəni port-channel təmin edəcəkdir,ona görə də port-channel 5-ci ve 6-ci interfeysləri port-channelə salırıq.

6

Technet_WLC(config)#interface port-channel 10

Technet_WLC(config-if)#no shutdown

Technet_WLC(config)#interface range tenGigabitEthernet 1/0/5-6

Technet_WLC(config-if-range)#channel-group 10 mode ?

  active     Enable LACP unconditionally

  auto       Enable PAgP only if a PAgP device is detected

  desirable  Enable PAgP unconditionally

  on         Enable Etherchannel only

  passive    Enable LACP only if a LACP device is detected

 

Technet_WLC(config-if-range)#channel-group 10 mode desirable

 

 

Indi isə WLC üzərində SSH konfiqurasiya edək.

Technet_WLC(config)#ip domain-name technet_az

Technet_WLC(config)#crypto key generate rsa

The name for the keys will be: Technet_WLC.technet_az

Choose the size of the key modulus in the range of 360 to 4096 for your

  General Purpose Keys. Choosing a key modulus greater than 512 may take

  a few minutes.

How many bits in the modulus [512]: 1024

 

Technet_WLC(config)#username zeynal privilege 15 secret zeynal

Technet_WLC(config)#line vty 0 4

Technet_WLC(config-line)#login local

Technet_WLC(config-line)#transport input ssh

 

Web browser üzərindən biz GUİ vasitəsilə WLC-ni konfiqurasiya edə bilərik. Lakin biz CLI ilə konfiqurasiya edəcəyik.7

İndi isə WLC-də vlan-lar yaradaq ,bildiyiniz kimi switch üzərində 10 və 20 vlan-lar mövcud idi.

Technet_WLC(config)#vlan 10

Technet_WLC(config-vlan)#vlan 20

 

Technet_WLC(config)#interface Port-channel10

Technet_WLC(config-if)#description SWITCH-e geden uplink

Technet_WLC(config-if)#switchport mode trunk

Technet_WLC(config-if)#switchport trunk allowed vlan 1,10,20

Technet_WLC(config-if)#ip dhcp relay information trusted

Technet_WLC(config-if)# ip dhcp snooping trust

 

DHCP snooping üçün isə aşağıdakı komandaları icra edək

Technet_WLC(config)#ip dhcp snooping vlan 1,10,20

Technet_WLC(config)#no ip dhcp snooping information option

Technet_WLC(config)#ip dhcp snooping wireless bootp-broadcast enable

 

show license right-to-use komandası ilə biz WLC-nin  nə qədər  access point dəstəkləndiyini baxa bilərik.

8

 

Göründüyü kimi WLC 1000 ədəd access point dəstəkləyir.WLC-də indi isə vaxtı konfiqurasiya edək.

 

Technet_WLC#clock set 18:55:25 Jan 3 2015

Technet_WLC#show wireless country configured

 Configured Country………………………..: US  – United States

 Configured Country Codes

        US  – United States : 802.11a Indoor,Outdoor/ 802.11b / 802.11g

 

Bu komanda ilə WLC-nin hansı ölkə üçün konfiqurasiya olunduğunu görürük.Bunu Türkiyə üçün dəyişək.İlk öncə aşağıdakı komandaları icra edək.

Technet_WLC (config)#ap dot11 24ghz shutdown

Technet_WLC(config)#ap dot11 5ghz shutdown9

 

WLC-yə default gateway verək.

Technet_WLC(config)#ip default-gateway 172.16.20.1

WLC-də indi isə WLAN konfiqurasiya edək.

10

 

WLAN Zeynal olacaq ,bizim SSİD isə Technet olacaqdır. Pre-shared key isə Qafqaz2008 olacaqdır.

Ölkə dəyişdiyimiz zaman shutdown etdiyimiz radio kanallari indi no shutdown edərək açaq.

11

12

 

Göründüyü kimi access pointlər 172 aralığından İP alıblar.

13

 

Hər üç access pointin Join olduğunu görürük.

Indi isə kompyuterdə və telefonda yoxlayaq.

14 15

 

Göründüyü kimi hər ikisi bizm DHCP pooldan İp alir və hər ikisində internet mövcuddur.

Təşəkkürlər !

Müəllif: Zeynalabdin Hacılı

Səs: +10. Bəyənilsin Zəifdir

Müəllif: Araz Ayyubov

Şərhlər ( Cisco wireless controller nədir? )

  1. Çox gözəl movzudur. Təşəkkürlər. Davamını gözləyirik.

Şərh yazın