Cisco router vlan

Salam.

Sualım cisco routerlərdə vlan işlərinin necə olması ilə bağlıdır. Yəni switchdə vlan yaradırıq və ona portları assign edirik. Və ya portu trunk edirik. Amma routerdə “switchport” əmri yoxdur. O zaman routerdə vlan necə təyin edilir?

Səs: 0. Bəyənilsin Zəifdir

Baxılıb: 1853 dəfə

Cavablar ( 15 )

  1. Ömər bəy,

    vlan layer 2 texnologiyadır, router daxilində vlan ötürücülüyü yoxdur. Əgər router məsələn 800 seriya cisco-dursa hansının ki üstundə 4 sviç portu var, bu portlarda vlan ayarlanması eyni olaraq sviç ayarları kimidir. Routerin portu sviçin trank portuna qoşulanda router vlanları bir birindən ayırsın deyə Routerdə ” subinterface” lər yaradılır. məsələn

    Capture

     

    bu halda sviçdə 3 vlan varsa: 10, 20, 30 router R1 və sviç S1- in ayarları belə olacaq

    s1

    interface fastethernet 0/1

    switchport mode trunk

    switchport trunk alloved vlan 10, 20, 30

    ———-

    R1

    interface fast 0/1.10 ( subinterface indeksi olan 10 rəqəmi şərti rəqəmdir, vlan id ilə eyni olmasına gərək yoxdurç amma belə olması rahat anlaşmağa kümək edir)

    encapsulation dot1q 10 ( sviçin trank portunda 10-cu vlandan trafiki alacaq)

    ip address 10.0.10.254 255.255.255.0

    interface fast 0/1.20

    encapsulation dot1q 20

    ip address 10.0.20.254 255.255.255.0

    interface fast 0/1.30

    encapsulation dot1q 30

    ip address 10.0.30.254 255.255.255.0

    ————–

    onu da qeyd edim ki, routerdə qeyd etdiyim şəkildə vlan yaratmağın məqsədi vlanlar arasında kompeterlərin bir biri ilə əlaqəsisnin qurulmasıdır. Bunun üçün routerdə qeyd edilən ip-lər uyğun vlanda olan kompüterlərin gateway-i olacaq.

    Routerdə sadəcə subinterface yaradıb vlan id-sını qeyd edib subinterfacelərə ip verməyəriksə bunun heç bir anlamı olmaz, router bu halda vlan üzrə heç bir əməliyyat görməyəcək.

  1. Bir daha salam. Bir neçə araşdırmadan sonra özüm cavabını tapdım.

    Layer 2 routerlərdə vlan yaratmaq üçün subinterfacedən istifadə olunur və encapsulation dot1Q əmri ilə vlanı tanıdırıq.

    İkinci yolu isə Layer 3 routerlərdən istifadə etməkdir. Layer 3 routerlər həm routing həm də switching işlərini yerinə yetirir və biz orda vlan yarada bilərik.

  2. Ömər bəy,

    vlan layer 2 texnologiyadır, router daxilində vlan ötürücülüyü yoxdur. Əgər router məsələn 800 seriya cisco-dursa hansının ki üstundə 4 sviç portu var, bu portlarda vlan ayarlanması eyni olaraq sviç ayarları kimidir. Routerin portu sviçin trank portuna qoşulanda router vlanları bir birindən ayırsın deyə Routerdə ” subinterface” lər yaradılır. məsələn

    Capture

     

    bu halda sviçdə 3 vlan varsa: 10, 20, 30 router R1 və sviç S1- in ayarları belə olacaq

    s1

    interface fastethernet 0/1

    switchport mode trunk

    switchport trunk alloved vlan 10, 20, 30

    ———-

    R1

    interface fast 0/1.10 ( subinterface indeksi olan 10 rəqəmi şərti rəqəmdir, vlan id ilə eyni olmasına gərək yoxdurç amma belə olması rahat anlaşmağa kümək edir)

    encapsulation dot1q 10 ( sviçin trank portunda 10-cu vlandan trafiki alacaq)

    ip address 10.0.10.254 255.255.255.0

    interface fast 0/1.20

    encapsulation dot1q 20

    ip address 10.0.20.254 255.255.255.0

    interface fast 0/1.30

    encapsulation dot1q 30

    ip address 10.0.30.254 255.255.255.0

    ————–

    onu da qeyd edim ki, routerdə qeyd etdiyim şəkildə vlan yaratmağın məqsədi vlanlar arasında kompeterlərin bir biri ilə əlaqəsisnin qurulmasıdır. Bunun üçün routerdə qeyd edilən ip-lər uyğun vlanda olan kompüterlərin gateway-i olacaq.

    Routerdə sadəcə subinterface yaradıb vlan id-sını qeyd edib subinterfacelərə ip verməyəriksə bunun heç bir anlamı olmaz, router bu halda vlan üzrə heç bir əməliyyat görməyəcək.

  3. Salam. Cavabınız üçün minnətdaram. Əla izahdır. İki sualım da var:

    1) mən ip phoneları 20 vlan olan svitç portuna, ip phonun pc pprtuna isə kompyuteri salsam və kompyuterləri 10cu vlanda olan gatevvay ilə əlaqələndirə bilərəmmi?

    2) option 150 olan dhcp yalnız ip phonelar üçünmü keçərlidir? Yəni ip phone option 150 olan dhcpden ip adres alacaq, kompyuterlər isə sadə dhcpdən?

  4. Ömər bəy,

    1) bəli, telefon 20-ci vlan-da, telefonun PC portuna qoşulmuş kompüter 10-cu vlanda olması üçün sviçin portunda  novbəti ayar ediləcək.

    ——————–

    switchport mode access

    switchport access vlan 10

    switchport voice vlan 20 ( bu kommandanın telefon tərəfindən tanınması üçün portda cdp protokol aktiv olmalıdır)

    spanning-tree portfast

    ———————–

    2) DHCP serverdə option 150 – dhcp vasitəsi ilə mövcud tftp server barədə məlumat vermək üçündür. Bu option 150 tək telefon üçün deyildir və dhcp poolda option 150-nin olması o demək deyil ki telefon bu pooldan ip alacaq. telefon ip alma prosesində əsas məqam

    • telefonun hansı vlan-da olmasıdır ( voice vlan 20)
    • həmin vlanda  gateway-in (dhcp serverin) ipsinin nə olmasıdır,
    • hansı dhcp pool-da qeyd olunan şəbəkənin vlanın gateway-i ilə üst-üstə düşməsidir

    üstdəki misala uygun olaraq ayarlar aşağıdakı kimidir

    ————————————-
    s1

    interface fastethernet 0/1
    description link to R1 Router port Fast0/1
    switchport mode trunk
    switchport trunk alloved vlan 10, 20, 30
    !
    interface fastethernet 0/2
    description ip phone and PC
    switchport mode access
    switchport access vlan 10
    switchport voice vlan 20
    spanning-tree portfast
    !

    ———-

    R1
    ip dhcp pool 10
    network 10.0.10.0 255.255.255.0
    dns-server 8.8.8.8 8.8.4.4
    default-router 10.0.10.254

    ip dhcp pool 20
    network 10.0.20.0 255.255.255.0
    option 150 ip x.x.x.x ( x.x.x.x telefona aid call managerin ip-si)
    dns-server 8.8.8.8 8.8.4.4
    default-router 10.0.20.254
    interface fastethernet 0/1
    description link to S1 switch port fast0/1
    interface fast 0/1.10
    encapsulation dot1q 10
    ip address 10.0.10.254 255.255.255.0
    interface fast 0/1.20
    encapsulation dot1q 20
    ip address 10.0.20.254 255.255.255.0

  5. Salam.

    Daha bir sual ortaya çıxdı. Mən bir başa call manager istifadə etmədən ( yəni cucm kimi hər hansı qurğu) router daxilində olan “telephony-service”dan istifadə etmək istəyirəm. O zaman elə routerin öz ipsini option 150-dən sonra göstərməliyəm və bu 20-ci vlan olan subinterfeysin ip-i olacaq. Düz başa düşdüm?

  6. Ömər bəy,

    option 150 teyin etməkdə heç bir məhdudiyyat yoxdur. Ora call managerin ip-sini yazacaqsız. bu İP telephony service-i ayarlayarkən, mütlək ayarlardan biri olan ip source-address X.X.X.X (cme-in telefonlara xidmət verəcəyi cə option 150-də qeyd ediləcək ip-si)  ayarındakı ip olacaqdır, routerin nterfacelərindən istənilən birinin ip-si ola bilər

    • Təşəkkür edirəm Aydın bəy. Əziyyət çəkib suallarımı cavablandırdığınıız üçün.

      Sualım çıxsa yenə yazacam. Çox sağolun.

  7. Buyurun Ömər bəy,  cavabı bəyəndizsə bəyənilsin düyməsini bassanız kifayətdir. Sualınız yarandıqda uyğun bağlıqla yeni sual yaradın, kömək edə bilərəmsə məmnuniyyətlə köməyimi əsirgəmərəm.

  8. Bəli artıq etmişəm.

    Sadəcə Packet Tracerdə cme tapmadım. Hətta telephony servise da yoxdu. GNS3 yoxlayacam görək nə alınır.

    Təşəkkürlər.

  9. Dostlar salamlar,

    Maraqlı sual-cavabdır.

    Ömər bəy, bir neçə əlavə etmək istərdim:

    Option 150 DHCPdə mövcud olan bir çox option-lardan biridir. Bu option DHCP sazlaması zamanı TFTP server informasiyasını ötürmək üçün istifadə olunur. Telefoniya sazlaması zamanı biz ip telefonlar üçün əlavə sazlama faylların ötürülməsi üçün TFTP serverdən istifadə edirik. Bu TFTP server hər hansə əlavə bir server və yaxud sazladığımız routerin özü də ola bilər. Misal olaraq bir ip telefonların qoşulduğu zaman avtomatik olaraq yeni əməliyyat sisteminin TFTPdən köçürməsinə də nail ola bilərik.

    Laboratoriya üçün isə GNS dən istifadə edə bilərsiniz. İSR routerlardan istifadə edərək CME sazlayıb, öz kompüterinizdə virtual communicatordan istifadə edərək öz sazlamalarınızı yoxlaya bilərsiniz.
    Hörmətlə,

    Rizvan

  10. Salam Rizvan bəy.

    Əvvəlcə qeyd edim ki, dünən testi etdim və ip-phoneları işə sala bildim. Cisco İP Communicator programı ilə.

    Prosesdən belə anladım ki, biz routerdə telephony-service tənzimləyə biliriksə deməli həmin router özü cme ( yəni lazımi tftp server) kimi çıxış edə bilir. Düzmü anlamışam? Yəni ip source-address-də routerin elə özünü göstərdiyimizdə ip phonelar bütün tənzimləmələr üçün bu routerə müraciət edir?

    Bu topici yaratmaqda əsas məqsədim əslində fərqli idi lakin sual-cavab ilə bir çox suala cavab tapdım.

    Başda da qeyd etdiyim kimi mən biraz qarışıq şəbəkə istifadə etmək istəyirdim. Yəni voice üçün fərqli vlan, pc-lər üçün fərqli vlan. Amma bir sual ortaya çıxdı ki, real həyatda adətən ip phone üçün ayrıca port və pc üçün ayrıca port olmur adətən. İP phone-un pc portundan istifadə etmək daha pratikdir. Bundan sonra yuxarıdakı suallar meydana çıxdı.

    Dünən sadə pc-lərsiz və vlansız ip-phone tənzimləmələri edə bildim. Bugün Royal bəyin verdiyi qaydalardan istifadə edərək qarışıq şəbəkəni quracam.

  11. Ömər bəy,

    Düzgün vurğuladınız. Sazladığınız router özü həm də TFTP server kimi istifadə oluna bilər. Biz DHCP də Option 150-də həmin routerin İP addressini göstərməklə, İP telefonların TFTP üçün bizim router-ə müraciət etməsinə nail ola bilirik.

    Xatırlatmaq istərdim ki, real həyatda da voice və data üçün ayrı VLANlar istifadə olunur. Lakin bu o demək deyil ki biz həm telefon, həm də PC üçün svitçin fərqli fiziki portlarından istifadə edəcəyik. Bir qayda olaraq İP telefon svitçə qoşulur, PC isə öz növbəsində İP telefona qoşulur. Bundan sonra isə biz svitçin portunda voice və data vlan tanıdaraq, hər iki trafficin ayrı-ayrılıqda ötürülməsinə nail ola bilirik.

    Laboratoriyanın nəticələrini bölüşməyi unutmayın.

    Hörmətlə,

    Rizvan

  12. Salam. Labda bir balaca çətinlik çəkirəm. Problem budur ki, GNS3-də yalniz ip communicator istifadə etmək olur. Bu zaman biz onun PC portunu istifadə edə bilmirik. Packet Tracerdə İP phone var. Lakin CME dəstəyi olan router tapmadım. Yəni telephony-service əmrini tanıyan.

    Əgər mən svitçdə voice vlan və data vlanı ayırsam o zaman softphone necə işləyəcək? Çünki İP communicator kompyuterin mac-addresini istifadə edir. O zaman kompyuterin lan portu necə çıxış edəcək şəbəkədə?

    Packet Tracer üçün bir yolu varsa bilənlər paylaşsın xahiş edirəm.

  13. Salam dostlar. Hər birinizə ayrı-ayrılıqda təşəkkür edirəm. LAB alındı.

    Packet Tracerdə 2811 routerində var imiş cme. Tam istədiyim kimi qura bildim.

     

    Capture

  14. Bir sualım yarandı lab vaxtı. Mən auto assignauto-reg-ephone əmrlərindən istifadə etdim tez olsun deyə. Lakin yalnız phonelara ip address verdi. Nə number nə də button config vermədi. Onları da avtomatlaşdırma var yəqin ki. O necə icra olunur?

Cavab yazın